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ECUTEK ON SENTRA SR TURBO 
 

INTRODUCTION  

 

Welcome and thank you for being a customer of Visconti Tuning!  This guide is broken into sections 

which you can jump around between by clicking on each of the chapters below.  Each section contains 

detailed summaries of the information you’ll need to take full advantage of this product.  To get 

started you’re going to need to install and familiarize yourself with EcuTek’s ProECU and our Tuner 

Assist software. 

 

 

Thanks again for putting your faith in Visconti Tuning!  Let’s get started. 
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FAMILIARIZING YOURSELF WITH TUNING TERMINOLOGY 

 

Before we dive right into “How to Use EcuTek to Flash Your ECU with V-TUNE,” let’s review a few 

quick things that will help to better explain this whole process and the terminology we use throughout 

these documents. 

When working with EcuTek’s software and our calibrations, you’ll be working with what are called 

“ROM files” (Read Only Memory).  It’s important to understand that these read only files are the actual 

hard-coded instruction sets used by EcuTek and the car’s ECU to literally run the engine.  These files 

are also commonly referred to as Maps, Tunes and Calibrations, and will be used interchangeably 

throughout these documents.  Calibration is generally the most accurate depicter of a ROM file, since 

the ROM calibrates the ECU to a state where it can effectively and efficiently maintain control of the 

parameters that make the engine run.  The Calibration is made up of dozens of Maps, which can be 

thought of as graphs, and which guide all individual parameters that are required for the engine to 

make power.  When we Tune these Maps, we’re making adjustments for increased efficiency and 

better use of the many changing variables and environmental factors that affect the engine’s 

performance.  The resulting collection of tuned maps is a Tuned Calibration.  Therefore, you’ll be 

working with both your Stock Calibration, or “factory setup” and our Tuned Calibrations. 

In order for us to produce the right tuned calibration file for your specific car, we need several key 

pieces of information; all of which are contained in the car’s stock ROM file.  In order to extract this 

data, you’ll need to perform what is elegantly referred to as a “ROM Dump.”  This is the process of 

copying (as opposed to “flashing”) the existing ROM file from the ECU to your laptop.  In other words, 

the reverse process of flashing.    

So now let’s talk about “Flashing,” and what is actually occurring during this process.  Just like with 

the ROM Dump process, when you flash your ECU, you’re using EcuTek’s ProECU software to exchange 

information between your laptop and the car’s ECU.  But 

flashing the ECU differs in that you’re actually overwriting 

specific areas of memory that control the maps and other 

critical parameters of the engine.  The purpose of this is to 

calibrate or tune the ECU to make better and more 

efficient use of its mechanical components.  This allows us 

to create more power, new and improved features, better 

safety mechanisms, different fueling adaptations and in 

some cases, even increased fueling efficiency (higher MPG).  

These are the goals and the challenges that made Visconti 

Tuning and the results of which, are what set us apart 

from the rest! 
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INSTALLING ECUTEK PROECU SOFTWARE ON YOUR WINDOWS LAPTOP 

 

A foreword on MacBooks: 
You can use a MacBook to run ProECU but you will need to be 
running a stand-alone version of Windows.  A stand-alone version 
is different from an emulated version.  There are several OSX 
apps available that will emulate Windows inside OSX, like 
Parallels, VMWare Fusion and Virtual Box.  These are NOT viable 
options even though they may appear to work initially.  Without 
getting too technical, the problem lies in these applications also 
emulating USB ports inside the emulated version of Windows.  
EcuTek’s software requires the USB dongle key to be plugged in at 
all times to run its software.  When working with emulated USB ports, there is the potential for conflicts to arise 
during critical stages of the flash and as we’ll discuss in more detail later on, it’s very important that there are no 
interruptions while your computer is exchanging information with your car’s ECU. 
To run ProECU with a MacBook, you must use OSX’s Bootcamp application.  Just like with the emulation software 
mentioned, you will need either an image (.iso) of Windows or a physical CD/DVD to install from.  More 
information can be found on Apple’s website or by clicking here to download the Bootcamp Manual.  From this 
point forward, we will only offer support to PC users or Bootcamp users. 
 

Please Note: DO NOT plug either the USB Dongle or OBDII USB into your computer until drivers are installed! 

1. The first step we’ll need to take to begin this process is to install EcuTek’s ProECU Software on 

your laptop.  Their software can be downloaded by visiting support.vtune.us and clicking on the 

EcuTek App Downloader link.   

 

 

2. When App Downloader is finished, double-click on it to begin the installation process.  You’ll be 

met with the following introduction screens, which you simply need to click “Next” through. 

 

  

 

http://www.apple.com/
http://manuals.info.apple.com/en_US/Boot_Camp_Install-Setup.pdf
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3. At this stage, you will be installing the drivers for both the USB Dongle Key and your OBDII-to-

USB Cable.  Again, for the smoothest installation process possible, PLEASE do not plug either 

device into your computer before the proper drivers are installed!  All options on the Software 

Components screen should be checked by default, so click Next and Windows will ask you to 

verify the driver installation with the following window: 

 

 

4. It is highly recommended that you check the “Always trust software from EcuTek International” 

box, which will prevent this window from occurring again and also from windows hanging on 

the next driver install.  After installing the drivers for both devices you’ll be using to run the 

ProECU Software with, you’ll be asked to plug each one in separately beginning with the OBDII 

cable.  Luckily the installer uses pictures to show when to plug in each device, as shown below. 

 

  

 

5. After the drivers for both devices are correctly installed, you should see a confirmation bubble 

pop up from the taskbar, as seen in the image below.  This confirms that both devices were 

recognized and installed correctly with the proper drivers. 

 

 

 

6. Leave both devices connected as you proceed through the rest of the installation.  Next 

EcuTek’s App Downloader software will update all components of the ProECU software with the 

latest patches and revisions.  It is very important that you allow all updates to be downloaded 

and installed! 
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7. After the notification above pops up stating, “Your ProECU installation has now been updated,” 

the entire ProECU Software installation has completed successfully and all updates to the core 

components have been made, but we’re not done quite yet!  Now that the software itself is 

completely up-to-date, we need to make sure it also has the latest database of manufacturer 

configuration files, ECU ID’s and everything else to identify the latest models. 

 

 

 

 

 

8. The first time you open ProECU, you’ll be asked for one last round of updates, which again is to 

ensure compatibility with the latest supported makes and models. 

 

 

  

 

 

9. And finally, after all updates are successfully installed, you’ll be left with a simple, elegant 

ProECU Software bar, like the one you see below.  Also notice the two solid green lights on the 

ProECU bar, which indicate proper communication with the CAN & K-Line interface of the OBDII 

Cable.  You are now ready to proceed to the next section of this guide! 

 

 

 

 

  



6 | P a g e  
 

STEP-BY-STEP INSTRUCTIONS FOR ROM DUMP 

 

1. The first step to pulling the ROM Dump from your ECU is to load up EcuTek’s ProECU software.  

You should also get in the habit of closing all unrelated programs down and disabling your anti-

virus.  It’s good practice to eliminate as much “interference” as possible beforehand, because 

once you reach the point where you’re passing files to and from your ECU, it is very 

important that the process go uninterrupted. 

 

2. With your laptop ready to begin and the included USB dongle key plugged in, let’s go ahead and 

establish the link we need between the ProECU Software and your car’s ECU.  Start by locating 

your car’s OBDII port, which is under the dash/steering column centered roughly to the left 

side of the brake pedal (see pictures below). 

 

 

  

 

3. With the OBDII Cable securely plugged into the car’s OBDII Port and its single solid green light 

confirming the connection (shown in the picture above), plug the USB end of the OBDII Cable 

into a free USB port on your computer, keeping in mind that the USB Dongle Key must remain 

plugged in while running ProECU.  As we saw during installation, the ProECU Toolbar should 

confirm the connection by lighting up green in the right hand status boxes, as shown in the 

picture below. 

 

 
 

IMPORTANT: at no point during either the ROM Dump or flashing process will you be 
starting your engine.  Any reference or instruction to “turn the car on,” means turning the 
key, or pushing the start button (twice) to the ON position.  The best way to avoid any 
accidental engine starts is to keep your feet off all foot pedals while you are linked to the 
OBDII port. 

 

4. Another good habit to be in before you begin any communication with the ECU, is to make sure 

all accessory switches are in the off position.  This includes your headlights, HVAC system (A/C), 

and even your stereo and Bluetooth accessories.  It’s also important to make sure both your 

car’s battery and your laptop are fully charged.  Again, we don’t want any disruptions while 

connected to the ECU.  If all of the above steps have been followed and you have the two 

green status lights in the toolbar, you’re ready to begin pulling the ROM File from your ECU.  

Go ahead and turn your key (or push start button) to the on position. 
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5. First we need to have the software detect your vehicle so it can load the correct ProECU Tools.  

To do this, click on the Tools menu in ProECU -> then click Detect Vehicle and let the software 

try and figure out which car you have.   

 

 
 

6. If it fails to detect your vehicle, you’ll most likely see the following error message: 

 

 
 

If that’s the case, make sure that all drivers were installed correctly and neither the USB 

Dongle nor OBDII Cable were plugged in prior to the driver install.  Also, be sure that the car is 

in the “ON” position (as opposed to just the ACC or accessory position), that all software 

updates were downloaded and installed correctly and that you still have two green status lights.  

Alternatively, you can manually select your vehicle by choosing that option, which is also found 

under the Tools menu. 

 

7. After a successful detection, made by choosing Detect Vehicle (or by manually selecting it), 

you should see the Select Tuning Tool window come up.  From here you will see the option to 

Program Engine ECU (which should be the top choice).  Select Program Engine ECU and click 

OK.  
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8. In some instances, you will receive a warning message saying, “You are not running the 

recommended vehicle interface driver version.”  As long as the Installed Driver Version is 

higher than the Recommended Driver Version, this is nothing to worry about.  If not, there 

are still updates that need to be installed.  Click OK to advance to the next screen. 

 

9. The next window that loads will be the Programming Tools Window (shown below).  This is the 

window you’ll be using to perform both the ECU ROM Dump and where you Flashing your tune.  

 

 
 

 

 

There are several buttons and a lot of information available here but it is an easy interface to 

use, especially after performing the important functions a few times through.  The diagram 

above highlights the important buttons you’ll be using and what they do.  But since this section 

of the guide deals with performing a ROM Dump, you’ll want to focus your attention on the 

“Dump Details for EcuTek” button on the bottom left of the window (shown in blue).  

 

10 To perform a ROM Dump simply click on Query ECU, followed by Dump Details for EcuTek 

(Highlighted in Blue in screenshot).  If you have an unsupported ECU, the following warning 

message is produced.  Click OK to continue. 

 
 

10.1 You’ll see another alert window pop up which is just confirming that you’re intending to 

produce an “information file,” which is the actual ROM Dump you’ll be producing for us and 

submitting through email.  Go ahead and click OK. 
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10.2 This will begin the “building” process of the ROM file from your ECU.  Again, it can’t really be 

said enough; it is very important that this process and any process where information is being 

sent to and from the ECU, not be interrupted!  You can keep track of the progress of the build 

in the lower left hand corner of the “Programming Tools” window, as shown below. 

 

 

10.3 Once the process is complete and the ROM File has been built, you’ll see the following message 

confirming the ROM File’s save location and asking if you would now like to submit the file to 

EcuTek.  We do not want to submit the file to EcuTek, because they won’t be the one’s 

working with the file.  That’s our job so go ahead and click cancel.  

 

 

 
 

 

 

10.4     That’s it!  You’re done building the ROM File. The file is automatically saved to this folder    

address:  C:\EcuTek\RomDumps\ 

 

IMPORTANT: After an ECU Reset (Which happens after a ROM DUMP), the ECU put into a 
diagnostic mode next time the engine is started. This mode lasts about 30 seconds when 
the car left to idle. DO NOT hit the gas pedal or drive the car during this period. 

 

  

The file is going to be named something very similar to what’s shown in the Information 

window pictured above: “ProECU_RomDump_NissanECM_xxxxx__Nissan_370Z_MT_2012_US_...” 

Also make note that all ROM Dumps will be of extension .romdump, as opposed to the 

Calibration files which will be .bin.  The information in the filename (and of course, contained 

within the file itself) will be very specific to your car, which is why we need this file to build 

your calibration. 

 

Please follow the next section to submit your ROM DUMP 
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STEP-BY-STEP INSTRUCTIONS - INSTALLING TUNER ASSIST & SUBMITTING ROMDUMP 

 

 

IMPORTANT: Tuner Assist will only work after EcuTek ProECU has been 
successfully installed on your computer. Tuner Assist requires your EcuTek Dongle 
Plugged in to run. Make sure you’re connected to the internet the first time you 
use the software! 

 

11 Tuner Assist is how you will manage both your Tune and Log Files, it will also allow you to submit 

diagnostic and ROM DUMP Information. Navigate to support.vtune.us and download Tuner Assist. 

 11.1 Run Tuner Assist Installer   

 

  

  
 

 

11.2 After the installation has completed you will see a Tuner Assist Icon on your desktop, double 

click on that. 

 
 

11.3 You’ll see a message reminding you to have your EcuTek Dongle Plugged in. 
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11.4  The first time you open Tuner Assist you’ll see a “My Profile” window appear, please 

completely fill that out and click “Update” to start using the software. 

 

  
 

 

11.5  With Tuner Assist open and connected to the internet please submit your ROMDUMP by 

selecting Send Diagnostic Information” from the Help menu. 

 

 

 
 

 

 

11.6  If you received this message while producing a ROMDUMP please wait, we will email 

you when EcuTek has added support to your vehicle. This normally takes up 3-5 

business days!  

 

 

 

 
 

 

 

Please email us if you do not hear from us after 5 business days. 
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STEP-BY-STEP INSTRUCTIONS FOR DOWNLOADING YOUR TUNE FILE 

After you submit your ROM DUMP we will build your map and place it in your “Custom Calibrations 

Folder”.  

12. Open Tuner Assist 

 

12.1 Select the files you would like and click “Download Selected Files”.  

 

 
 

Please wait while our calibration server builds the tune files for your EcuTek Dongle. This can take 

up to 5 minutes depending on your internet connection and how many files you are trying to 

download at once. 

 

12.2 Once the download is completed you see the files appear in your download folder. 

 

Double clicking any of the files will open EcuTek ProECU. From there you can easily start data 

logging or install the tune by selecting the Programming Tool under the ‘Tools’ Menu.  

 

*The Programming Tool will automatically select the last opened file in ProECU.* 
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 HOW TO CONDUCT ADVANCED DATA LOGGING FOR TROUBLESHOOTING & REVIEW 

 

 

 

 

Live Data Logging 

Data Logging is an important tool we use to get an extremely detailed representation of how 
your engine is performing.  It will record and log several key variables that are instrumental 
in assessing engine health and performance, and allow us to quickly diagnose any issues 
that may arise or even find areas of the calibration that can be better adapted to your 
specific vehicle or setup. 

After flashing in the V-Tune calibration, we recommend running a datalog shortly thereafter, 
and submitting it through our support console for review.  Here’s how to begin the process: 

1. Start by loading up the EcuTek ProECU software, making sure that the USB Dongle 
Key is connected beforehand.  With the ProECU bar loaded, go ahead and connect 
your laptop to your car’s ECU using the OBDII-to-USB cable.  Just like in the 
previous sections, you should have the two green status bars in ProECU and an 
active green light on the OBDII cable confirming the connection with the ECU. 
 

2. With everything linked up between 
your car and your laptop, go ahead 
and start your engine.  To open the 
Live Data window, you simply need to 
open the most recently flashed ROM 
file. You can do this two ways.  You 
can open Tuner Assist and double 
click on your downloaded tune file – 
This will open ProECU with your ROM 
file open and ready to log. In ProECU 
you can also select File -> Open ROM 
File or  File -> Recent ROMs.   

 

3. With the ROM File open, you can see 
the large list of variables (shown to the 
right) that can be logged with the 
ProECU software.  However, even 
though your engine is running, you 
won’t see them updating in real-time 
just yet.  Also notice that each variable 
has a check box next to it which you 
can use to select whether the data 
from this parameter is logged or not in the data file you’re about to produce.  Don’t 
worry about which variables need to be checked and which ones don’t.  By default, 
we have already set this list up to monitor the important ones we want you to log. 

 

 

Advanced Data Logging 

Feature Tutorial 
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4. The first time you datalog using ProECU, 
you’ll want to set up a few things in the 
Live Data window.  It is suggested that 
you show the additional columns for 
minimum and maximum values for each 
parameter.  To do this, right click in the 
toolbar under “Live Data” where “Name, 
Units, and Current” reside and click on the 
options to show “Minimum” and 
“Maximum,” as shown in the picture to the 
right.  This of course will keep track of the 
spectrum of the variables and the range 
they extend to and from, which is 

important.  After enabling these columns, 
click View -> Save Rom Editor Layout as 
Default to save this view as the default.  

 

 

5. With everything loaded up and connected, we’re ready to open the connection 
between the OBDII port and your laptop.  Go ahead and click on the “Map Access” 
button to begin this connection and start the flow of data.  You should now see the 
Current, Minimum and Maximum categories updating and changing in real time.   

 
Important: If you get the following error 
message after clicking on “Map Access,” the 
ROM file you have opened does not match the 
contents of your ECU, which means you have 
not flashed in the ROM file you have opened 
and are attempting to log.  You must be using 
the most recently flashed ROM file to log data. 

 

6. After clicking Map Access, you 
should notice a couple of things.  The 
Map Access button is now 
highlighted and you have a new 
status bar that appears above the list 
of variables that shows a cycling 
green status bar.  This indicates an 
active connection and streaming data 
from your ECU.  Also notice the 
status bar currently has a RED 
rectangle around it, which indicates 
the data is not being recorded.  To 
create a datalog simply click the “Log 
To File” button.   
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7. Once Log To File is enabled, you will see the button itself highlighted (just like the 
Map Access button) and the RED rectangle from before will change to GREEN to 
confirm that the data is now being logged.  The log will be continuously recording 
the output from the engine until the button is pressed again to stop logging.   
 

 
 
In order to produce the best datalogs, you’re going to want to show a couple of 
WOT (wide-open throttle) pulls, preferably in 3rd gear to show sufficient load on the 
engine.  Second gear pulls are acceptable but do not provide as much time or detail 
to pinpoint any issues that may be occurring. 
 

8. After logging a few pulls and a few minutes of normal driving, you can comfortably 
end the log session as this will more than likely produce enough data to get an 
accurate read on the health of the engine.  After you’ve safely pulled over and 
parked, go ahead and click the ‘Log To File’ button again to end the log session. 
This will produce and save a time-stamped log file to the default logging folder, 
which can be found at C:\EcuTek\MapAccessLogs. 

 

Tip: The full path and filename will be shown when you hover the mouse over the Log To File 
button.   

 

9.  Submit your log using Tuner Assist!  

 

You’ll receive an email when the logs have been successfully submitted. 

 

 

 

 



16 | P a g e  
 

RACEROM FEATURES & HOW TO USE THEM 

 

Coming Soon.  


